summaryrefslogtreecommitdiffstats
path: root/debian/patches/sys-auxv-header.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/sys-auxv-header.diff')
-rw-r--r--debian/patches/sys-auxv-header.diff46
1 files changed, 46 insertions, 0 deletions
diff --git a/debian/patches/sys-auxv-header.diff b/debian/patches/sys-auxv-header.diff
new file mode 100644
index 0000000..c88d2d8
--- /dev/null
+++ b/debian/patches/sys-auxv-header.diff
@@ -0,0 +1,46 @@
+# DP: Check for the sys/auxv.h header file.
+
+Index: b/src/gcc/configure.ac
+===================================================================
+--- a/src/gcc/configure.ac
++++ b/src/gcc/configure.ac
+@@ -1339,6 +1339,7 @@ AC_HEADER_TIOCGWINSZ
+ AC_CHECK_HEADERS(limits.h stddef.h string.h strings.h stdlib.h time.h iconv.h \
+ fcntl.h ftw.h unistd.h sys/auxv.h sys/file.h sys/time.h sys/mman.h \
+ sys/resource.h sys/param.h sys/times.h sys/stat.h sys/locking.h \
++ sys/auxv.h \
+ direct.h malloc.h langinfo.h ldfcn.h locale.h wchar.h)
+
+ # Check for thread headers.
+Index: b/src/gcc/config.in
+===================================================================
+--- a/src/gcc/config.in
++++ b/src/gcc/config.in
+@@ -1957,6 +1957,12 @@
+ #endif
+
+
++/* Define to 1 if you have the <sys/auxv.h> header file. */
++#ifndef USED_FOR_TARGET
++#undef HAVE_SYS_AUXV_H
++#endif
++
++
+ /* Define to 1 if you have the <sys/file.h> header file. */
+ #ifndef USED_FOR_TARGET
+ #undef HAVE_SYS_FILE_H
+Index: b/src/gcc/config/rs6000/driver-rs6000.cc
+===================================================================
+--- a/src/gcc/config/rs6000/driver-rs6000.cc
++++ b/src/gcc/config/rs6000/driver-rs6000.cc
+@@ -35,6 +35,10 @@ along with GCC; see the file COPYING3.
+ # include <link.h>
+ #endif
+
++#ifdef HAVE_SYS_AUXV_H
++# include <sys/auxv.h>
++#endif
++
+ #if defined (__APPLE__) || (__FreeBSD__)
+ # include <sys/types.h>
+ # include <sys/sysctl.h>