summaryrefslogtreecommitdiffstats
path: root/libGeoIP/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:22:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:22:53 +0000
commit3b149631f0eb732049e04fa0c89d09c7aa2376f9 (patch)
tree7049356b06fcdcdaf9dbae476f55a43942e7c25f /libGeoIP/Makefile.am
parentInitial commit. (diff)
downloadgeoip-3b149631f0eb732049e04fa0c89d09c7aa2376f9.tar.xz
geoip-3b149631f0eb732049e04fa0c89d09c7aa2376f9.zip
Adding upstream version 1.6.12.upstream/1.6.12upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--libGeoIP/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/libGeoIP/Makefile.am b/libGeoIP/Makefile.am
new file mode 100644
index 0000000..f85cd00
--- /dev/null
+++ b/libGeoIP/Makefile.am
@@ -0,0 +1,19 @@
+lib_LTLIBRARIES = libGeoIP.la
+
+EXTRA_DIST = Makefile.vc GeoIP_internal.h pread.c pread.h
+
+AM_CPPFLAGS = -DGEOIPDATADIR=\"$(pkgdatadir)\" -Wall
+
+libGeoIP_la_SOURCES = GeoIP.c GeoIP_deprecated.c GeoIPCity.c regionName.c timeZone.c
+include_HEADERS = GeoIP.h GeoIPCity.h
+
+libGeoIP_la_LDFLAGS = -no-undefined -version-info @GEOIP_VERSION_INFO@
+
+GeoIP.lo GeoIP.o: GeoIP.c GeoIP_deprecated.c GeoIP.h
+
+GeoIPCity.lo GeoIPCity.o: GeoIPCity.c GeoIP.h
+
+regionName.lo regionName.o: regionName.c
+
+timeZone.lo timeZone.o: timeZone.c
+