summaryrefslogtreecommitdiffstats
path: root/plug-ins/lighting/images/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:13:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:13:10 +0000
commit3c57dd931145d43f2b0aef96c4d178135956bf91 (patch)
tree3de698981e9f0cc2c4f9569b19a5f3595e741f6b /plug-ins/lighting/images/Makefile.am
parentInitial commit. (diff)
downloadgimp-3c57dd931145d43f2b0aef96c4d178135956bf91.tar.xz
gimp-3c57dd931145d43f2b0aef96c4d178135956bf91.zip
Adding upstream version 2.10.36.upstream/2.10.36
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'plug-ins/lighting/images/Makefile.am')
-rw-r--r--plug-ins/lighting/images/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/plug-ins/lighting/images/Makefile.am b/plug-ins/lighting/images/Makefile.am
new file mode 100644
index 0000000..55dfbde
--- /dev/null
+++ b/plug-ins/lighting/images/Makefile.am
@@ -0,0 +1,29 @@
+## Process this file with automake to produce Makefile.in
+
+STOCK_IMAGES = \
+ stock-intensity-ambient-high.png \
+ stock-intensity-ambient-low.png \
+ stock-intensity-diffuse-high.png \
+ stock-intensity-diffuse-low.png \
+ stock-reflectivity-diffuse-high.png \
+ stock-reflectivity-diffuse-low.png \
+ stock-reflectivity-specular-high.png \
+ stock-reflectivity-specular-low.png \
+ stock-reflectivity-highlight-high.png \
+ stock-reflectivity-highlight-low.png
+
+EXTRA_DIST = $(STOCK_IMAGES)
+
+noinst_DATA = stock-pixbufs.h
+CLEANFILES = $(noinst_DATA) stock-icons.list
+
+stock-icons.list: $(STOCK_IMAGES) Makefile.am
+ ( rm -f $@; \
+ for image in $(STOCK_IMAGES); do \
+ echo $$image | \
+ sed -e 's|.*/||' -e 's|-|_|g' -e 's|\.png$$||' >> $@; \
+ echo " $(srcdir)/$$image" >> $@; \
+ done )
+
+$(srcdir)/stock-pixbufs.h: stock-icons.list
+ $(GDK_PIXBUF_CSOURCE) --raw --build-list `cat stock-icons.list` > $(@F)