summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index bf8fe12..97ce206 100755
--- a/debian/rules
+++ b/debian/rules
@@ -91,6 +91,7 @@ override_dh_auto_build-indep:
cd build-gpgv-win32/common && $(WIN32_FLAGS) $(MAKE) libgpgrl.a
cd build-gpgv-win32/common && $(WIN32_FLAGS) $(MAKE) libsimple-pwquery.a
cd build-gpgv-win32/kbx && $(WIN32_FLAGS) $(MAKE) libkeybox.a
+ cd build-gpgv-win32/regexp && $(WIN32_FLAGS) $(MAKE) _unicode_mapping.c
cd build-gpgv-win32/regexp && $(WIN32_FLAGS) $(MAKE) libregexp.a
cd build-gpgv-win32/g10 && $(WIN32_FLAGS) $(MAKE) gpgv.exe
strip build-gpgv-win32/g10/gpgv.exe
@@ -104,6 +105,9 @@ override_dh_shlibdeps:
dpkg-shlibdeps -Tdebian/dirmngr.substvars -dRecommends debian/dirmngr/usr/lib/gnupg/dirmngr_ldap -dDepends debian/dirmngr/usr/bin/dirmngr*
dh_shlibdeps -Ndirmngr
+execute_before_dh_autoreconf:
+ echo "Developer change history can be found in the source tarball. See NEWS for high-level changes." > ChangeLog
+
# visualizations of package dependencies:
debian/%.png: debian/%.dot
dot -T png -o $@ $<