summaryrefslogtreecommitdiffstats
path: root/scd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--scd/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/scd/Makefile.am b/scd/Makefile.am
index 32be6ab..4539731 100644
--- a/scd/Makefile.am
+++ b/scd/Makefile.am
@@ -1,3 +1,4 @@
+# Makefile.am - scd
# Copyright (C) 2002, 2003, 2005 Free Software Foundation, Inc.
#
# This file is part of GnuPG.
@@ -26,7 +27,10 @@ AM_CPPFLAGS = $(LIBUSB_CPPFLAGS)
include $(top_srcdir)/am/cmacros.am
if HAVE_W32_SYSTEM
-scdaemon_robjs = $(resource_objs) scdaemon-w32info.o
+scdaemon_rc_objs = $(resource_objs) scdaemon-w32info.o
+scdaemon-w32info.o : scdaemon.w32-manifest ../common/w32info-rc.h
+else
+scdaemon_rc_objs = $(resource_objs)
endif
AM_CFLAGS = $(LIBGCRYPT_CFLAGS) \
@@ -48,4 +52,5 @@ scdaemon_SOURCES = \
scdaemon_LDADD = $(libcommonpth) \
$(LIBGCRYPT_LIBS) $(KSBA_LIBS) $(LIBASSUAN_LIBS) $(NPTH_LIBS) \
$(LIBUSB_LIBS) $(GPG_ERROR_LIBS) \
- $(LIBINTL) $(DL_LIBS) $(NETLIBS) $(LIBICONV) $(scdaemon_robjs)
+ $(LIBINTL) $(DL_LIBS) $(NETLIBS) $(LIBICONV) $(scdaemon_rc_objs)
+scdaemon_DEPENDENCIES = $(scdaemon_rc_objs)