summaryrefslogtreecommitdiffstats
path: root/sm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--sm/Makefile.am33
1 files changed, 27 insertions, 6 deletions
diff --git a/sm/Makefile.am b/sm/Makefile.am
index 0bc7640..db8b35e 100644
--- a/sm/Makefile.am
+++ b/sm/Makefile.am
@@ -17,9 +17,17 @@
## Process this file with automake to produce Makefile.in
-EXTRA_DIST = ChangeLog-2011 gpgsm-w32info.rc gpgsm.w32-manifest.in
+EXTRA_DIST = ChangeLog-2011 \
+ gpgsm-w32info.rc gpgsm.w32-manifest.in
bin_PROGRAMS = gpgsm
+noinst_PROGRAMS = $(module_tests) $(module_maint_tests)
+
+if DISABLE_TESTS
+TESTS =
+else
+TESTS = $(module_tests)
+endif
AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(KSBA_CFLAGS) $(LIBASSUAN_CFLAGS)
@@ -27,10 +35,8 @@ AM_CPPFLAGS = -DKEYBOX_WITH_X509=1
include $(top_srcdir)/am/cmacros.am
if HAVE_W32_SYSTEM
-gpgsm_robjs = $(resource_objs) gpgsm-w32info.o
-gpgsm-w32info.o : gpgsm.w32-manifest
-else
-gpgsm_robjs =
+gpgsm_rc_objs = $(resource_objs) gpgsm-w32info.o
+gpgsm-w32info.o : gpgsm.w32-manifest ../common/w32info-rc.h
endif
gpgsm_SOURCES = \
@@ -65,8 +71,23 @@ common_libs = ../kbx/libkeybox509.a $(libcommon)
gpgsm_LDADD = $(common_libs) ../common/libgpgrl.a \
$(LIBGCRYPT_LIBS) $(KSBA_LIBS) $(LIBASSUAN_LIBS) \
$(GPG_ERROR_LIBS) $(LIBREADLINE) $(LIBINTL) \
- $(LIBICONV) $(gpgsm_robjs) $(extra_sys_libs) $(NETLIBS)
+ $(LIBICONV) $(gpgsm_rc_objs) $(extra_sys_libs) $(NETLIBS)
gpgsm_LDFLAGS = $(extra_bin_ldflags)
+gpgsm_DEPENDENCIES = $(gpgsm_rc_objs)
+
+module_tests = t-minip12
+module_maint_tests =
+
+t_common_src =
+t_common_ldadd = $(libcommon) $(LIBGCRYPT_LIBS) $(KSBA_LIBS) \
+ $(GPG_ERROR_LIBS) $(LIBINTL) $(LIBICONV)
+
+
+t_minip12_CFLAGS = -DWITHOUT_NPTH=1 \
+ $(LIBGCRYPT_CFLAGS) $(KSBA_CFLAGS) $(GPG_ERROR_CFLAGS)
+t_minip12_SOURCES = $(t_common_src) t-minip12.c minip12.c
+t_minip12_LDADD = $(t_common_ldadd) $(NETLIBS)
+
# Make sure that all libs are build before we use them. This is
# important for things like make -j2.