summaryrefslogtreecommitdiffstats
path: root/tests/migrations
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/migrations/Makefile.am2
-rw-r--r--tests/migrations/Makefile.in23
-rw-r--r--tests/migrations/all-tests.scm1
-rwxr-xr-xtests/migrations/from-classic.scm2
-rw-r--r--tests/migrations/run-tests.scm1
5 files changed, 15 insertions, 14 deletions
diff --git a/tests/migrations/Makefile.am b/tests/migrations/Makefile.am
index 6d2d2e8..4eaacb9 100644
--- a/tests/migrations/Makefile.am
+++ b/tests/migrations/Makefile.am
@@ -53,7 +53,7 @@ check: xcheck
.PHONY: xcheck
xcheck:
- $(TESTS_ENVIRONMENT) $(abs_top_builddir)/tests/gpgscm/gpgscm \
+ $(TESTS_ENVIRONMENT) $(abs_top_builddir)/tests/gpgscm/gpgscm$(EXEEXT) \
$(abs_srcdir)/run-tests.scm $(TESTFLAGS) $(TESTS)
EXTRA_DIST = common.scm run-tests.scm setup.scm all-tests.scm \
diff --git a/tests/migrations/Makefile.in b/tests/migrations/Makefile.in
index 0cc6786..42f505b 100644
--- a/tests/migrations/Makefile.in
+++ b/tests/migrations/Makefile.in
@@ -146,17 +146,16 @@ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/autobuild.m4 \
$(top_srcdir)/m4/codeset.m4 $(top_srcdir)/m4/gettext.m4 \
$(top_srcdir)/m4/gpg-error.m4 $(top_srcdir)/m4/iconv.m4 \
- $(top_srcdir)/m4/isc-posix.m4 $(top_srcdir)/m4/ksba.m4 \
- $(top_srcdir)/m4/lcmessage.m4 $(top_srcdir)/m4/ldap.m4 \
- $(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
- $(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/libassuan.m4 \
- $(top_srcdir)/m4/libgcrypt.m4 $(top_srcdir)/m4/nls.m4 \
- $(top_srcdir)/m4/npth.m4 $(top_srcdir)/m4/ntbtls.m4 \
- $(top_srcdir)/m4/pkg.m4 $(top_srcdir)/m4/po.m4 \
- $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/m4/readline.m4 \
- $(top_srcdir)/m4/socklen.m4 $(top_srcdir)/m4/sys_socket_h.m4 \
- $(top_srcdir)/m4/tar-ustar.m4 $(top_srcdir)/acinclude.m4 \
- $(top_srcdir)/configure.ac
+ $(top_srcdir)/m4/ksba.m4 $(top_srcdir)/m4/lcmessage.m4 \
+ $(top_srcdir)/m4/ldap.m4 $(top_srcdir)/m4/lib-ld.m4 \
+ $(top_srcdir)/m4/lib-link.m4 $(top_srcdir)/m4/lib-prefix.m4 \
+ $(top_srcdir)/m4/libassuan.m4 $(top_srcdir)/m4/libgcrypt.m4 \
+ $(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/npth.m4 \
+ $(top_srcdir)/m4/ntbtls.m4 $(top_srcdir)/m4/pkg.m4 \
+ $(top_srcdir)/m4/po.m4 $(top_srcdir)/m4/progtest.m4 \
+ $(top_srcdir)/m4/readline.m4 $(top_srcdir)/m4/socklen.m4 \
+ $(top_srcdir)/m4/sys_socket_h.m4 $(top_srcdir)/m4/tar-ustar.m4 \
+ $(top_srcdir)/acinclude.m4 $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
DIST_COMMON = $(srcdir)/Makefile.am $(am__DIST_COMMON)
@@ -626,7 +625,7 @@ check: xcheck
.PHONY: xcheck
xcheck:
- $(TESTS_ENVIRONMENT) $(abs_top_builddir)/tests/gpgscm/gpgscm \
+ $(TESTS_ENVIRONMENT) $(abs_top_builddir)/tests/gpgscm/gpgscm$(EXEEXT) \
$(abs_srcdir)/run-tests.scm $(TESTFLAGS) $(TESTS)
# We need to depend on a couple of programs so that the tests don't
diff --git a/tests/migrations/all-tests.scm b/tests/migrations/all-tests.scm
index 421f696..ba95f5c 100644
--- a/tests/migrations/all-tests.scm
+++ b/tests/migrations/all-tests.scm
@@ -28,6 +28,7 @@
(map (lambda (name)
(test::scm #f
+ #f
(path-join "tests" "migrations" name)
(in-srcdir "tests" "migrations" name)))
(parse-makefile-expand (in-srcdir "tests" "migrations" "Makefile.am")
diff --git a/tests/migrations/from-classic.scm b/tests/migrations/from-classic.scm
index b473d70..2033a4a 100755
--- a/tests/migrations/from-classic.scm
+++ b/tests/migrations/from-classic.scm
@@ -26,7 +26,7 @@
(call-check `(,@GPG --list-secret-keys)))
(define (assert-migrated)
- (unless (file-exists? ".gpg-v21-migrated")
+ (unless (or (file-exists? ".gpg-v21-migrated") (file-exists? "gpg-v21-migrated"))
(error "Not migrated"))
(for-each
diff --git a/tests/migrations/run-tests.scm b/tests/migrations/run-tests.scm
index f44334c..d4db14f 100644
--- a/tests/migrations/run-tests.scm
+++ b/tests/migrations/run-tests.scm
@@ -23,5 +23,6 @@
(load-tests "tests" "migrations")
(map (lambda (name)
(test::scm #f
+ #f
(path-join "tests" "migrations" name)
(in-srcdir "tests" "migrations" name))) tests)))