summaryrefslogtreecommitdiffstats
path: root/test/bench/garbage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/bench/garbage/Makefile')
-rw-r--r--test/bench/garbage/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/bench/garbage/Makefile b/test/bench/garbage/Makefile
new file mode 100644
index 0000000..c10ef0a
--- /dev/null
+++ b/test/bench/garbage/Makefile
@@ -0,0 +1,23 @@
+# Copyright 2010 The Go Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style
+# license that can be found in the LICENSE file.
+
+ALL=\
+ parser\
+ peano\
+ tree\
+ tree2\
+
+all: $(ALL)
+
+%: %.go
+ go build $*.go stats.go
+
+%.bench: %
+ time ./$*
+
+bench: $(addsuffix .bench, $(ALL))
+
+clean:
+ rm -f $(ALL)
+