summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/control2
-rwxr-xr-xdebian/helpers/getdefault.pl5
3 files changed, 15 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f3ee1fd..4510287 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+golang-defaults (2:1.21~3) unstable; urgency=medium
+
+ * Extend golang-go to ppc64, but golang-any still points to gccgo-go
+ on ppc64.
+ This helps packages that want to use golang-go to on ppc64 even if it
+ violates the baseline requirements.
+
+ -- Shengjing Zhu <zhsj@debian.org> Wed, 21 Feb 2024 18:51:50 +0800
+
golang-defaults (2:1.21~2) unstable; urgency=medium
* Team upload
diff --git a/debian/control b/debian/control
index f904b34..351f641 100644
--- a/debian/control
+++ b/debian/control
@@ -18,7 +18,7 @@ Vcs-Git: https://salsa.debian.org/go-team/compiler/golang-defaults.git
Homepage: https://golang.org
Package: golang-go
-Architecture: amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64el riscv64 s390x
+Architecture: amd64 arm64 armel armhf i386 mips mips64el mipsel ppc64 ppc64el riscv64 s390x
Multi-Arch: same
Depends: golang-${golang:Version}-go,
golang-src (>= ${source:Version}),
diff --git a/debian/helpers/getdefault.pl b/debian/helpers/getdefault.pl
index 0c12743..49ca758 100755
--- a/debian/helpers/getdefault.pl
+++ b/debian/helpers/getdefault.pl
@@ -7,6 +7,11 @@ use strict;
use Debian::Debhelper::Dh_Lib;
+if (hostarch() eq "ppc64") {
+ printf("gccgo-go\n");
+ exit 0;
+}
+
my %known_packages = map { $_ => 1 } getpackages('arch');
if (exists($known_packages{'golang-go'})) {
printf("golang-go\n");