summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:15:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:15:41 +0000
commit38a2eb4ed098f741e10e3e6e0d940d500942461d (patch)
treea108b5e50a22c0213503ef92b940fddd7eb2d5fd /debian/rules
parentAdding upstream version 2.5.0. (diff)
downloadicingaweb2-module-businessprocess-38a2eb4ed098f741e10e3e6e0d940d500942461d.tar.xz
icingaweb2-module-businessprocess-38a2eb4ed098f741e10e3e6e0d940d500942461d.zip
Adding debian version 2.5.0-1.debian/2.5.0-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1a6aa4f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+
+MODULE := businessprocess
+DEBDIR := debian/icingaweb2-module-$(MODULE)
+
+%:
+ dh ${@}
+
+override_dh_auto_install:
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -and -not -name ".pc" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
+
+ # remove useless files
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/packaging
+ rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/.travis.yml
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/library/vendor/php-diff/example
+
+execute_after_dh_installdocs:
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name AUTHORS -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name COPYING -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name LICENSE -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name README -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name "*.md" -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -type d -empty -delete
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/doc