summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f8bd75e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+MODULE := cube
+DEBDIR := debian/icingaweb2-module-$(MODULE)
+
+%:
+ dh ${@}
+
+override_dh_auto_install:
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -and -not -name ".pc" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
+
+execute_after_dh_installdocs:
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name AUTHORS -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name COPYING -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name LICENSE -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name README -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name "*.md" -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -type d -empty -delete
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/doc