summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:30:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:30:51 +0000
commit5a0da279c29d31fbb0351c68157a4f6846158533 (patch)
treef79345923d070ad47e5b499b5b5358da4930fef8 /debian/rules
parentAdding upstream version 0.3.3. (diff)
downloadicingaweb2-module-toplevelview-5a0da279c29d31fbb0351c68157a4f6846158533.tar.xz
icingaweb2-module-toplevelview-5a0da279c29d31fbb0351c68157a4f6846158533.zip
Adding debian version 0.3.3-3.debian/0.3.3-3debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..dffb642
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+
+MODULE := toplevelview
+DEBDIR := debian/icingaweb2-module-$(MODULE)
+
+%:
+ dh ${@}
+
+override_dh_auto_install:
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -and -not -name ".pc" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
+
+ # remove useless files
+ rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/.mailmap
+ rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/docker-compose.dev.yml
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/test
+ find debian -name '.git*' -exec rm -f {} +
+
+execute_after_dh_installdocs:
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name AUTHORS -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name COPYING -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name LICENSE -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name README -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name "*.md" -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -type d -empty -delete
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/doc
+ rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/public/js/vendor/codemirror/SOURCE
+ rm -f $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/public/js/vendor/codemirror/VERSION