summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:31:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:31:28 +0000
commit9222f840e2ffc6253d8290160f29ec9d176ad37d (patch)
treee5391da810e7922bf7f9396c9b1fe3cb1723a4c7 /debian/rules
parentAdding upstream version 1:1.3.2. (diff)
downloadicingaweb2-module-x509-9222f840e2ffc6253d8290160f29ec9d176ad37d.tar.xz
icingaweb2-module-x509-9222f840e2ffc6253d8290160f29ec9d176ad37d.zip
Adding debian version 1:1.3.2-1.debian/1%1.3.2-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..33cd111
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+MODULE := x509
+DEBDIR := debian/icingaweb2-module-$(MODULE)
+
+%:
+ dh ${@} --with phpcomposer
+
+override_dh_auto_install:
+ mkdir -p $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -and -not -name ".pc" -exec cp -a {} $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) \;
+
+execute_after_dh_installdocs:
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name AUTHORS -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name COPYING -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name LICENSE -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name README -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -name "*.md" -exec rm -f {} \;
+ find $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE) -type d -empty -delete
+ rm -rf $(DEBDIR)/usr/share/icingaweb2/modules/$(MODULE)/doc