summaryrefslogtreecommitdiffstats
path: root/src/util/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 11:50:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 11:50:49 +0000
commitc853ffb5b2f75f5a889ed2e3ef89b818a736e87a (patch)
tree7d13a0883bb7936b84d6ecdd7bc332b41ed04bee /src/util/CMakeLists.txt
parentInitial commit. (diff)
downloadinkscape-c853ffb5b2f75f5a889ed2e3ef89b818a736e87a.tar.xz
inkscape-c853ffb5b2f75f5a889ed2e3ef89b818a736e87a.zip
Adding upstream version 1.3+ds.upstream/1.3+dsupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/util/CMakeLists.txt')
-rw-r--r--src/util/CMakeLists.txt58
1 files changed, 58 insertions, 0 deletions
diff --git a/src/util/CMakeLists.txt b/src/util/CMakeLists.txt
new file mode 100644
index 0000000..7c76d10
--- /dev/null
+++ b/src/util/CMakeLists.txt
@@ -0,0 +1,58 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+set(util_SRC
+ action-accel.cpp
+ document-fonts.cpp
+ expression-evaluator.cpp
+ format_size.cpp
+ funclog.cpp
+ pool.cpp
+ font-collections.cpp
+ share.cpp
+ object-renderer.cpp
+ paper.cpp
+ preview.cpp
+ statics.cpp
+ recently-used-fonts.cpp
+ units.cpp
+ ziptool.cpp
+
+
+ # -------
+ # Headers
+ action-accel.h
+ cached_map.h
+ cast.h
+ const_char_ptr.h
+ document-fonts.h
+ enums.h
+ expression-evaluator.h
+ font-collections.h
+ fixed_point.h
+ format.h
+ format_size.h
+ forward-pointer-iterator.h
+ funclog.h
+ longest-common-suffix.h
+ object-renderer.h
+ optstr.h
+ pages-skeleton.h
+ paper.h
+ parse-int-range.h
+ pool.h
+ preview.h
+ recently-used-fonts.h
+ reference.h
+ scope_exit.h
+ share.h
+ signal-blocker.h
+ statics.h
+ trim.h
+ units.h
+ ziptool.h
+ numeric/converters.h
+)
+
+add_inkscape_lib(util_LIB "${util_SRC}")
+target_link_libraries(util_LIB PUBLIC 2Geom::2geom)
+# add_inkscape_source("${util_SRC}")