summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/libcroco/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/libcroco/Makefile.am')
-rw-r--r--src/3rdparty/libcroco/Makefile.am72
1 files changed, 72 insertions, 0 deletions
diff --git a/src/3rdparty/libcroco/Makefile.am b/src/3rdparty/libcroco/Makefile.am
new file mode 100644
index 0000000..4b482f3
--- /dev/null
+++ b/src/3rdparty/libcroco/Makefile.am
@@ -0,0 +1,72 @@
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+
+SUBDIRS = src csslint docs tests win32
+
+PKG_CONFIG_FILE_UNINSTALLED=libcroco-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-uninstalled.pc
+PKG_CONFIG_FILE=libcroco-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@.pc
+
+pkgconfigdir=$(libdir)/pkgconfig
+pkgconfig_DATA=$(PKG_CONFIG_FILE)
+
+INCLUDE_DIR_NAME=@PACKAGE@-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@
+extraincludedir=$(includedir)/$INCLUDE_DIR_NAME
+
+CROCO_CONFIG_FILE_UNINSTALLED=croco-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-config-uninstalled
+CROCO_CONFIG_FILE=croco-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-config
+bin_SCRIPTS=$(CROCO_CONFIG_FILE)
+
+#man_MANS = croco-config.1
+
+EXTRA_DIST= croco-config.in $(PKG_CONFIG_FILE) TODO Doxyfile \
+HACKING COPYING.LIB COPYING libcroco.spec libcroco-zip.in \
+autogen.sh libcroco.doap config.h.win32.in config.h.win32
+
+all-local: $(PKG_CONFIG_FILE_UNINSTALLED) $(PKG_CONFIG_FILE) \
+$(CROCO_CONFIG_FILE_UNINSTALLED) $(CROCO_CONFIG_FILE)
+
+
+%-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@.pc: %.pc
+ cp $< $@
+
+%-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-uninstalled.pc: %.pc
+ cp $< $@
+
+%-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-config: %-config
+ cp $< $@
+
+%-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-config-uninstalled: %-config
+ cp $< $@
+
+clean-local: cleantest
+distclean-local:
+ -rm ./croco-0.6-config ./libcroco-0.6.pc ./libcroco-0.6-uninstalled.pc ./croco-0.6-config-uninstalled
+
+cleantest:
+ if test -x $(top_srcdir)/tests/testctl ; then $(top_srcdir)/tests/testctl cleanup ; fi
+
+cleantar:
+ @(rm -f libcroco*.tar.gz)
+ @(rm -rf $(top_srcdir)/rpmbuildroot)
+
+rpm: cleantar
+ @(mkdir -p $(top_srcdir)/rpmbuildroot ; $(MAKE) dist && rpmbuild -ta --buildroot $(top_srcdir)/rpmbuildroot $(distdir).tar.gz)
+
+test: all
+ if test -x $(top_srcdir)/tests/testctl ; then $(top_srcdir)/tests/testctl cleanup ; $(top_srcdir)/tests/testctl run ; fi
+
+apidoc:
+ if ! test -d docs/apis ; then mkdir -p docs/apis ; fi ;
+ doxygen Doxyfile
+
+ChangeLog:
+ $(AM_V_GEN) if test -f $(top_srcdir)/.git/HEAD; then \
+ git log --stat > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+
+