summaryrefslogtreecommitdiffstats
path: root/compat/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:20:54 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:20:54 +0000
commit7c720bec5600a9e607c875c670ca30ed351fa4ba (patch)
treec38c9bedf07616180feee6b91a1dbea038500b54 /compat/Makefile.am
parentInitial commit. (diff)
downloadiperf-7c720bec5600a9e607c875c670ca30ed351fa4ba.tar.xz
iperf-7c720bec5600a9e607c875c670ca30ed351fa4ba.zip
Adding upstream version 2.1.9+dfsg.upstream/2.1.9+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'compat/Makefile.am')
-rw-r--r--compat/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/compat/Makefile.am b/compat/Makefile.am
new file mode 100644
index 0000000..75ac787
--- /dev/null
+++ b/compat/Makefile.am
@@ -0,0 +1,22 @@
+noinst_LIBRARIES = libcompat.a
+
+AM_CPPFLAGS = @STRIP_BEGIN@ \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/include \
+ @STRIP_END@
+
+AM_CXXFLAGS = -Wall
+AM_CFLAGS = -Wall
+AM_LDFLAGS = -lrt
+
+libcompat_a_SOURCES = \
+ Thread.c \
+ error.c \
+ delay.c \
+ gettimeofday.c \
+ gettcpinfo.c \
+ inet_ntop.c \
+ inet_pton.c \
+ signal.c \
+ snprintf.c \
+ string.c