summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1251caa
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,18 @@
+AUTOMAKE_OPTIONS = foreign
+SUBDIRS = compat doc include src man
+
+AM_CPPFLAGS = @STRIP_BEGIN@ \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/include \
+ @STRIP_END@
+
+AM_CXXFLAGS = -Wall
+AM_FLAGS = -Wall
+
+EXTRA_DIST = t
+TEST_EXTENSIONS = .sh
+TESTS = t/t1_tcp.sh t/t2_tcp6.sh t/t3_udp.sh t/t4_udp6.sh \
+ t/t5_f.sh t/t6_filelong.sh t/t7_n.sh t/t8_num.sh \
+ t/t9_parallel.sh t/t10_dualtest.sh t/t11_tradeoff.sh \
+ t/t12_full_duplex.sh t/t13_reverse.sh
+