summaryrefslogtreecommitdiffstats
path: root/compat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'compat/Makefile.am')
-rw-r--r--compat/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/compat/Makefile.am b/compat/Makefile.am
new file mode 100644
index 0000000..75ac787
--- /dev/null
+++ b/compat/Makefile.am
@@ -0,0 +1,22 @@
+noinst_LIBRARIES = libcompat.a
+
+AM_CPPFLAGS = @STRIP_BEGIN@ \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/include \
+ @STRIP_END@
+
+AM_CXXFLAGS = -Wall
+AM_CFLAGS = -Wall
+AM_LDFLAGS = -lrt
+
+libcompat_a_SOURCES = \
+ Thread.c \
+ error.c \
+ delay.c \
+ gettimeofday.c \
+ gettcpinfo.c \
+ inet_ntop.c \
+ inet_pton.c \
+ signal.c \
+ snprintf.c \
+ string.c