summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-09 13:14:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-09 13:14:36 +0000
commit5e7a022920dd5834e3645bbf7e1ba5752ba633a1 (patch)
treecd44616fa76ffd61f590243fba3e370d5a7056f6 /debian/rules
parentAdding upstream version 6.8.0. (diff)
downloadiproute2-5e7a022920dd5834e3645bbf7e1ba5752ba633a1.tar.xz
iproute2-5e7a022920dd5834e3645bbf7e1ba5752ba633a1.zip
Adding debian version 6.8.0-1.debian/6.8.0-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules44
1 files changed, 44 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2adb152
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,44 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# for DEB_* variables
+include /usr/share/dpkg/default.mk
+include /usr/share/debhelper/dh_package_notes/package-notes.mk
+
+ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+ export CC=$(DEB_HOST_GNU_TYPE)-gcc
+ export HOSTCC=gcc
+ export PKG_CONFIG=$(DEB_HOST_GNU_TYPE)-pkg-config
+else
+ # some tools are to be built with the host compiler and intentionally
+ # ignore the *FLAGS, use them anyway in a non-cross build to make
+ # dpkg-buildflags-missing happy
+ export CBUILD_CFLAGS=$(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+endif
+
+ifneq (,$(findstring terse,$(DEB_BUILD_OPTIONS)))
+export VERBOSE=0
+else
+export VERBOSE=1
+endif
+
+export KERNEL_INCLUDE=./include
+export NETNS_RUN_DIR=/run/netns
+
+%:
+ dh $@
+
+execute_after_dh_clean:
+ make distclean
+
+override_dh_auto_test:
+ # upstream test suite needs root and leaves machine unclean, skip it
+
+# We are not shipping the ifstat binary as it conflicts with another Debian
+# package, so avoid shipping the manpage as well. See #873818
+override_dh_install:
+ dh_install -Xifstat.8
+
+override_dh_auto_install:
+ dh_auto_install --destdir $(CURDIR)/debian/tmp/