summaryrefslogtreecommitdiffstats
path: root/src/fe-none/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:18:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:18:39 +0000
commitfff5217f02d91268ce90c8c05665602c059faaef (patch)
tree2ba24d32dc96eafe7ed0a85269548e76796d849d /src/fe-none/Makefile.am
parentInitial commit. (diff)
downloadirssi-fff5217f02d91268ce90c8c05665602c059faaef.tar.xz
irssi-fff5217f02d91268ce90c8c05665602c059faaef.zip
Adding upstream version 1.4.5.upstream/1.4.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--src/fe-none/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/fe-none/Makefile.am b/src/fe-none/Makefile.am
new file mode 100644
index 0000000..bbcd63f
--- /dev/null
+++ b/src/fe-none/Makefile.am
@@ -0,0 +1,21 @@
+bin_PROGRAMS = botti
+
+AM_CPPFLAGS = \
+ -I$(top_builddir) \
+ $(GLIB_CFLAGS)
+
+botti_DEPENDENCIES = @COMMON_NOUI_LIBS@
+
+botti_LDADD = \
+ @COMMON_NOUI_LIBS@ \
+ @PERL_LINK_LIBS@ \
+ @PERL_LINK_FLAGS@ \
+ @PROG_LIBS@
+
+botti_SOURCES = \
+ irssi.c
+
+noinst_HEADERS = \
+ module.h
+
+EXTRA_DIST = meson.build