summaryrefslogtreecommitdiffstats
path: root/irssi-config.h.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--irssi-config.h.in144
1 files changed, 144 insertions, 0 deletions
diff --git a/irssi-config.h.in b/irssi-config.h.in
new file mode 100644
index 0000000..6c0c0c0
--- /dev/null
+++ b/irssi-config.h.in
@@ -0,0 +1,144 @@
+/* irssi-config.h.in. Generated from configure.ac by autoheader. */
+
+/* Alternate filesystem prefix for Termux */
+#undef FHS_PREFIX
+
+/* Build with Capsicum support */
+#undef HAVE_CAPSICUM
+
+/* Define to 1 if you have the <dirent.h> header file. */
+#undef HAVE_DIRENT_H
+
+/* Define to 1 if you have the <dlfcn.h> header file. */
+#undef HAVE_DLFCN_H
+
+/* */
+#undef HAVE_GMODULE
+
+/* Define to 1 if you have the <inttypes.h> header file. */
+#undef HAVE_INTTYPES_H
+
+/* Define to 1 if you have the `otr' library (-lotr). */
+#undef HAVE_LIBOTR
+
+/* Define to 1 if you have the `utf8proc' library (-lutf8proc). */
+#undef HAVE_LIBUTF8PROC
+
+/* Build with socks support */
+#undef HAVE_SOCKS
+
+/* misc.. */
+#undef HAVE_SOCKS_H
+
+/* */
+#undef HAVE_STATIC_OTR
+
+/* */
+#undef HAVE_STATIC_PERL
+
+/* Define to 1 if you have the <stdint.h> header file. */
+#undef HAVE_STDINT_H
+
+/* Define to 1 if you have the <stdio.h> header file. */
+#undef HAVE_STDIO_H
+
+/* Define to 1 if you have the <stdlib.h> header file. */
+#undef HAVE_STDLIB_H
+
+/* Define to 1 if you have the <strings.h> header file. */
+#undef HAVE_STRINGS_H
+
+/* Define to 1 if you have the <string.h> header file. */
+#undef HAVE_STRING_H
+
+/* Define to 1 if you have the <sys/ioctl.h> header file. */
+#undef HAVE_SYS_IOCTL_H
+
+/* Define to 1 if you have the <sys/resource.h> header file. */
+#undef HAVE_SYS_RESOURCE_H
+
+/* Define to 1 if you have the <sys/socket.h> header file. */
+#undef HAVE_SYS_SOCKET_H
+
+/* Define to 1 if you have the <sys/stat.h> header file. */
+#undef HAVE_SYS_STAT_H
+
+/* Define to 1 if you have the <sys/time.h> header file. */
+#undef HAVE_SYS_TIME_H
+
+/* Define to 1 if you have the <sys/types.h> header file. */
+#undef HAVE_SYS_TYPES_H
+
+/* Define to 1 if you have the <sys/utsname.h> header file. */
+#undef HAVE_SYS_UTSNAME_H
+
+/* Define to 1 if you have the `term.h' header. */
+#undef HAVE_TERM_H
+
+/* Define to 1 if you have the <unistd.h> header file. */
+#undef HAVE_UNISTD_H
+
+/* Define to the sub-directory where libtool stores uninstalled libraries. */
+#undef LT_OBJDIR
+
+/* Define to the address where bug reports for this package should be sent. */
+#undef PACKAGE_BUGREPORT
+
+/* Define to the full name of this package. */
+#undef PACKAGE_NAME
+
+/* Define to the full name and version of this package. */
+#undef PACKAGE_STRING
+
+/* Define to the one symbol short name of this package. */
+#undef PACKAGE_TARNAME
+
+/* Define to the home page for this package. */
+#undef PACKAGE_URL
+
+/* Define to the version of this package. */
+#undef PACKAGE_VERSION
+
+/* printf()-format for uoff_t, eg. "u" or "lu" or "llu" */
+#undef PRIuUOFF_T
+
+/* The size of `int', as computed by sizeof. */
+#undef SIZEOF_INT
+
+/* The size of `long', as computed by sizeof. */
+#undef SIZEOF_LONG
+
+/* The size of `long long', as computed by sizeof. */
+#undef SIZEOF_LONG_LONG
+
+/* The size of `off_t', as computed by sizeof. */
+#undef SIZEOF_OFF_T
+
+/* Define to 1 if all of the C90 standard headers exist (not just the ones
+ required in a freestanding environment). This macro is provided for
+ backward compatibility; new code need not use it. */
+#undef STDC_HEADERS
+
+/* true color support in terminal */
+#undef TERM_TRUECOLOR
+
+/* What type should be used for uoff_t */
+#undef UOFF_T_INT
+
+/* */
+#undef UOFF_T_LONG
+
+/* */
+#undef UOFF_T_LONG_LONG
+
+/* use GRegex for regular expressions */
+#undef USE_GREGEX
+
+/* Number of bits in a file offset, on hosts where this is settable. */
+#undef _FILE_OFFSET_BITS
+
+/* Define for large files, on AIX-style hosts. */
+#undef _LARGE_FILES
+
+/* Define to 'int' if <sys/socket.h> doesn't define. */
+#undef socklen_t