summaryrefslogtreecommitdiffstats
path: root/src/irc/dcc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/irc/dcc/meson.build')
-rw-r--r--src/irc/dcc/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/irc/dcc/meson.build b/src/irc/dcc/meson.build
new file mode 100644
index 0000000..0c3d706
--- /dev/null
+++ b/src/irc/dcc/meson.build
@@ -0,0 +1,31 @@
+# this file is part of irssi
+
+libirc_dcc_a = static_library('irc_dcc',
+ files(
+ 'dcc-autoget.c',
+ 'dcc-chat.c',
+ 'dcc-get.c',
+ 'dcc-queue.c',
+ 'dcc-resume.c',
+ 'dcc-send.c',
+ 'dcc-server.c',
+ 'dcc.c',
+ ),
+ include_directories : rootinc,
+ implicit_include_directories : false,
+ dependencies : dep)
+
+install_headers(
+ files(
+ 'dcc-chat.h',
+ 'dcc-file-rec.h',
+ 'dcc-file.h',
+ 'dcc-get.h',
+ 'dcc-queue.h',
+ 'dcc-rec.h',
+ 'dcc-send.h',
+ 'dcc-server.h',
+ 'dcc.h',
+ 'module.h',
+ ),
+ subdir : incdir / 'src' / 'irc' / 'dcc')