summaryrefslogtreecommitdiffstats
path: root/src/otr/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/otr/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/otr/meson.build b/src/otr/meson.build
new file mode 100644
index 0000000..5b7d256
--- /dev/null
+++ b/src/otr/meson.build
@@ -0,0 +1,27 @@
+# this file is part of irssi
+
+shared_module('otr_core',
+ files(
+ 'key.c',
+ 'otr-fe.c',
+ 'otr-formats.c',
+ 'otr-module.c',
+ 'otr-ops.c',
+ 'otr.c',
+ ),
+ include_directories : rootinc,
+ implicit_include_directories : false,
+ name_suffix : module_suffix,
+ install : true,
+ install_dir : moduledir,
+ dependencies : dep,
+)
+
+# noinst_headers = files(
+# 'irssi-otr.h',
+# 'key.h',
+# 'module.h',
+# 'otr-fe.h',
+# 'otr-formats.h',
+# 'otr.h',
+# )