summaryrefslogtreecommitdiffstats
path: root/kBuild/doc/example1/libhello/Makefile.kmk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:21:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:21:29 +0000
commit29cd838eab01ed7110f3ccb2e8c6a35c8a31dbcc (patch)
tree63ef546b10a81d461e5cf5ed9e98a68cd7dee1aa /kBuild/doc/example1/libhello/Makefile.kmk
parentInitial commit. (diff)
downloadkbuild-29cd838eab01ed7110f3ccb2e8c6a35c8a31dbcc.tar.xz
kbuild-29cd838eab01ed7110f3ccb2e8c6a35c8a31dbcc.zip
Adding upstream version 1:0.1.9998svn3589+dfsg.upstream/1%0.1.9998svn3589+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'kBuild/doc/example1/libhello/Makefile.kmk')
-rw-r--r--kBuild/doc/example1/libhello/Makefile.kmk30
1 files changed, 30 insertions, 0 deletions
diff --git a/kBuild/doc/example1/libhello/Makefile.kmk b/kBuild/doc/example1/libhello/Makefile.kmk
new file mode 100644
index 0000000..674c8b3
--- /dev/null
+++ b/kBuild/doc/example1/libhello/Makefile.kmk
@@ -0,0 +1,30 @@
+# $Id: Makefile.kmk 2343 2009-04-19 21:44:50Z bird $
+## @file
+# kBuild Example no. 1 - libhello/Makefile.kmk - The libhello sub-makefile.
+#
+
+#
+# The author disclaims copyright to this example script and places
+# it in the public domain.
+#
+# include full-legal-disclaimer.kmk
+#
+
+SUB_DEPTH = ..
+include $(KBUILD_PATH)/subheader.kmk
+
+#
+# The targets.
+#
+LIBRARIES += libhello
+
+#
+# The hello world library.
+#
+libhello_TEMPLATE = ExampleNo1Exe
+libhello_SOURCES = libhello.c
+
+## @todo Create a DLL variant.
+
+include $(FILE_KBUILD_SUB_FOOTER)
+