summaryrefslogtreecommitdiffstats
path: root/src/fastdep/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/fastdep/Makefile121
-rw-r--r--src/fastdep/Makefile.kmk57
2 files changed, 178 insertions, 0 deletions
diff --git a/src/fastdep/Makefile b/src/fastdep/Makefile
new file mode 100644
index 0000000..91f4af1
--- /dev/null
+++ b/src/fastdep/Makefile
@@ -0,0 +1,121 @@
+# $Id: Makefile 2413 2010-09-11 17:43:04Z bird $
+
+#
+# Odin32 API
+#
+# Makefile for the Quick-and-Dirty dependency utility. (FastDep)
+#
+# Copyright (c) 1999-2010 knut st. osmundsen <bird-kBuild-spamx@anduin.net>
+#
+# GPL
+#
+
+
+!ifdef BUILD_SETUP_MAK
+
+
+#
+# Setup config
+#
+ALL_NO_DBGMEM = 1
+PATH_ROOT = ..\..
+!include $(PATH_ROOT)\$(BUILD_SETUP_MAK)
+
+#
+# Target config
+#
+TARGET_NAME = fastdep
+TARGET_MODE = EXE
+TARGET_NEEDED = 1
+TARGET_PUB_BASE = $(PATH_TOOLS)
+
+TARGET_OBJS =\
+$(PATH_TARGET)\fastdep.$(EXT_OBJ)\
+$(PATH_TARGET)\avl.$(EXT_OBJ)\
+
+TARGET_LIBS =\
+$(LIB_OS)\
+$(LIB_C_OBJ)
+
+#
+# Rules config
+#
+RULES_FORWARD =
+!include $(MAKE_INCLUDE_PROCESS)
+
+
+!else
+#
+# Directory macro.
+#
+ODIN32_BIN = $(ODIN32_TOOLS)
+
+
+#
+# Tell buildenvironment that we're making an VIO .exe.
+# Tell buildenvironment that we like to use static linked CRT.
+# Tell buildenvironment that we should not copy this into /bin.
+#
+EXETARGET = 1
+VIO = 1
+STATIC_CRT = 1
+NO_MAIN_BIN_COPY = 1
+
+
+#
+# include common definitions
+#
+!include ../../makefile.inc
+
+
+#
+# Addjust common definitions
+#
+!if "$(VAC3)" == "1" || "$(VAC36)" == "1"
+CFLAGS = $(CFLAGS) -W3 -Wall+ppt-ppc-inl-cnv-gnr-vft-gen-uni-ext- \
+!ifdef DEBUG
+ -O+ -Tm-
+!endif
+!endif
+
+
+#
+# Object files. Prefix with OBJDIR and one space before the '\'.
+#
+OBJS = \
+$(OBJDIR)\fastdep.obj \
+$(OBJDIR)\avl.obj
+
+
+#
+# Libraries. One space before the '\'.
+#
+LIBS = \
+$(RTLLIB) \
+os2386.lib
+
+
+#
+# Target name - name of the exe without extention and path.
+#
+TARGET = FastDep
+
+
+#
+# Includes the common rules.
+#
+!include $(ODIN32_POST_INC)
+
+
+#
+# We need all.
+#
+needed: all
+!endif
+
+
+#
+# NT version using Watcom C/C++.
+#
+fastdepnt.exe:
+ wcl386 -bt=nt -l=nt -d2 /hc /"option map" -DOS2FAKE=1 -I$(WATCOM)\h\nt fastdep.c avl.c os2fake-win.c /Fe=$@ kernel32.lib
diff --git a/src/fastdep/Makefile.kmk b/src/fastdep/Makefile.kmk
new file mode 100644
index 0000000..3467df9
--- /dev/null
+++ b/src/fastdep/Makefile.kmk
@@ -0,0 +1,57 @@
+# $Id: $
+## @file
+# Sub-makefile for testing the VAC308 tool / ancient dependency generator.
+#
+
+#
+# Copyright (c) 2007-2010 knut st. osmundsen <bird-kBuild-spamx@anduin.net>
+#
+# This file is part of kBuild.
+#
+# kBuild is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# kBuild is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with kBuild. If not, see <http://www.gnu.org/licenses/>
+#
+#
+
+SUB_DEPTH = ../..
+include $(KBUILD_PATH)/subheader.kmk
+
+
+#
+# The base package.
+#
+PROGRAMS += fastdep
+fastdep_TOOL = VAC308
+fastdep_SOURCES = avl.c fastdep.c
+fastdep_INCS = f:/toolkit/v4.52/h
+fastdep_LIBPATH = f:/toolkit/v4.52/lib
+
+
+LIBRARIES += libfastdep
+libfastdep_TOOL = VAC308
+libfastdep_SOURCES = avl.c fastdep.c
+libfastdep_INCS = f:/toolkit/v4.52/h
+
+LIBRARIES += libfastdll
+libfastdll_TOOL = VAC308
+libfastdll_SOURCES = fastdll.def
+
+DLLS += fastdll
+fastdll_TOOL = VAC308
+fastdll_SOURCES = fastdll.def avl.c fastdep.c
+fastdll_INCS = f:/toolkit/v4.52/h
+fastdll_LIBPATH = f:/toolkit/v4.52/lib
+
+
+include $(FILE_KBUILD_SUB_FOOTER)
+