summaryrefslogtreecommitdiffstats
path: root/modules/ta_update/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 20:37:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 20:37:50 +0000
commitc1f743ab2e4a7046d5500875a47d1f62c8624603 (patch)
tree709946d52f5f3bbaeb38be9e3f1d56d11f058237 /modules/ta_update/meson.build
parentInitial commit. (diff)
downloadknot-resolver-913a96f00351e791fb56b1cd60642cb5fc7f7683.tar.xz
knot-resolver-913a96f00351e791fb56b1cd60642cb5fc7f7683.zip
Adding upstream version 5.7.1.upstream/5.7.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'modules/ta_update/meson.build')
-rw-r--r--modules/ta_update/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/ta_update/meson.build b/modules/ta_update/meson.build
new file mode 100644
index 0000000..e1c074e
--- /dev/null
+++ b/modules/ta_update/meson.build
@@ -0,0 +1,21 @@
+# LUA module: ta_update
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+config_tests += [
+ ['ta_update', files('ta_update.test.lua'), ['snowflake']],
+]
+
+integr_tests += [
+ # NOTE: ta_update may pass in cases when it should fail due to race conditions
+ # To ensure reliability, deckard should introduce a time wait
+ ['ta_update', meson.current_source_dir() / 'ta_update.test.integr'],
+ ['ta_update.unmanagedkey', meson.current_source_dir() / 'ta_update.unmanagedkey.test.integr'],
+]
+
+lua_mod_src += [
+ files('ta_update.lua'),
+]
+
+install_data(
+ install_dir: modules_dir / 'ta_update',
+)