summaryrefslogtreecommitdiffstats
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 20:37:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 20:37:50 +0000
commitc1f743ab2e4a7046d5500875a47d1f62c8624603 (patch)
tree709946d52f5f3bbaeb38be9e3f1d56d11f058237 /tests/unit/meson.build
parentInitial commit. (diff)
downloadknot-resolver-c1f743ab2e4a7046d5500875a47d1f62c8624603.tar.xz
knot-resolver-c1f743ab2e4a7046d5500875a47d1f62c8624603.zip
Adding upstream version 5.7.1.upstream/5.7.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tests/unit/meson.build37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
new file mode 100644
index 0000000..b10789c
--- /dev/null
+++ b/tests/unit/meson.build
@@ -0,0 +1,37 @@
+# tests: unit
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+# mock module for test_module
+mock_cmodule_src = files([
+ 'mock_cmodule.c',
+])
+
+mock_cmodule_mod = shared_module(
+ 'mock_cmodule',
+ mock_cmodule_src,
+ name_prefix: '',
+ dependencies: libknot,
+ include_directories: mod_inc_dir,
+)
+
+# executables with tests
+foreach unit_test : unit_tests
+ exec_test = executable(
+ unit_test[0],
+ unit_test[1],
+ dependencies: [
+ contrib_dep,
+ libkres_dep,
+ libknot,
+ cmocka,
+ lmdb,
+ ],
+ )
+ test(
+ 'unit.' + unit_test[0],
+ exec_test,
+ suite: 'unit',
+ # they take very short time
+ kwargs: meson.version().version_compare('<0.52') ? {} : { 'priority': -5 },
+ )
+endforeach