summaryrefslogtreecommitdiffstats
path: root/python/libknot/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 19:05:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 19:05:44 +0000
commitb045529c40c83601909dca7b76a53498e9a70f33 (patch)
tree88371572105933fd950676c07b3a12163a0c9de0 /python/libknot/Makefile.am
parentInitial commit. (diff)
downloadknot-b045529c40c83601909dca7b76a53498e9a70f33.tar.xz
knot-b045529c40c83601909dca7b76a53498e9a70f33.zip
Adding upstream version 3.3.4.upstream/3.3.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'python/libknot/Makefile.am')
-rw-r--r--python/libknot/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/python/libknot/Makefile.am b/python/libknot/Makefile.am
new file mode 100644
index 0000000..4e6abc4
--- /dev/null
+++ b/python/libknot/Makefile.am
@@ -0,0 +1,21 @@
+EXTRA_DIST = \
+ libknot/__init__.py.in \
+ libknot/control.py \
+ libknot/dname.py \
+ libknot/probe.py \
+ pyproject.toml.in \
+ setup.py.in \
+ README.md
+
+clean-local:
+ -rm -rf dist *.egg-info
+
+dist: clean-local
+ @if hatchling -h &> /dev/null; then \
+ hatchling build; \
+ else \
+ python3 setup.py sdist; \
+ fi
+
+upload:
+ twine upload dist/*