summaryrefslogtreecommitdiffstats
path: root/python/knot_exporter/pyproject.toml.in
diff options
context:
space:
mode:
Diffstat (limited to 'python/knot_exporter/pyproject.toml.in')
-rw-r--r--python/knot_exporter/pyproject.toml.in45
1 files changed, 45 insertions, 0 deletions
diff --git a/python/knot_exporter/pyproject.toml.in b/python/knot_exporter/pyproject.toml.in
new file mode 100644
index 0000000..6846eb5
--- /dev/null
+++ b/python/knot_exporter/pyproject.toml.in
@@ -0,0 +1,45 @@
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[project]
+name = "knot_exporter"
+version = "@PACKAGE_VERSION@"
+description = "Prometheus exporter for Knot DNS"
+readme = "README.md"
+requires-python = ">=3.5"
+license = { text = "GPL-3.0" }
+authors = [
+ { name = "CZ.NIC, z.s.p.o.", email = "knot-dns@labs.nic.cz" },
+ { name = "Alessandro Ghedini", email = "alessandro@ghedini.me" },
+]
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: System Administrators",
+ "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+ "Programming Language :: Python :: 3",
+ "Topic :: Internet :: Name Service (DNS)",
+ "Topic :: System :: Systems Administration",
+]
+dependencies = [
+ "libknot",
+ "prometheus-client",
+ "psutil",
+]
+
+[project.urls]
+Documentation = "https://www.knot-dns.cz/documentation"
+Issues = "https://gitlab.nic.cz/knot/knot-dns/-/issues"
+Source = "https://gitlab.nic.cz/knot/knot-dns/-/tree/master/python/knot_exporter"
+
+[project.scripts]
+knot-exporter = "knot_exporter.knot_exporter:main"
+
+[tool.hatch.build]
+# don't filter by .gitignore
+ignore-vcs = true
+exclude = [
+ ".*",
+ "*.in",
+ "Makefile*",
+]