summaryrefslogtreecommitdiffstats
path: root/python/libknot/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'python/libknot/Makefile.am')
-rw-r--r--python/libknot/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/python/libknot/Makefile.am b/python/libknot/Makefile.am
new file mode 100644
index 0000000..4e6abc4
--- /dev/null
+++ b/python/libknot/Makefile.am
@@ -0,0 +1,21 @@
+EXTRA_DIST = \
+ libknot/__init__.py.in \
+ libknot/control.py \
+ libknot/dname.py \
+ libknot/probe.py \
+ pyproject.toml.in \
+ setup.py.in \
+ README.md
+
+clean-local:
+ -rm -rf dist *.egg-info
+
+dist: clean-local
+ @if hatchling -h &> /dev/null; then \
+ hatchling build; \
+ else \
+ python3 setup.py sdist; \
+ fi
+
+upload:
+ twine upload dist/*