summaryrefslogtreecommitdiffstats
path: root/xbmc/rendering/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 18:07:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 18:07:22 +0000
commitc04dcc2e7d834218ef2d4194331e383402495ae1 (patch)
tree7333e38d10d75386e60f336b80c2443c1166031d /xbmc/rendering/CMakeLists.txt
parentInitial commit. (diff)
downloadkodi-c04dcc2e7d834218ef2d4194331e383402495ae1.tar.xz
kodi-c04dcc2e7d834218ef2d4194331e383402495ae1.zip
Adding upstream version 2:20.4+dfsg.upstream/2%20.4+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'xbmc/rendering/CMakeLists.txt')
-rw-r--r--xbmc/rendering/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/xbmc/rendering/CMakeLists.txt b/xbmc/rendering/CMakeLists.txt
new file mode 100644
index 0000000..c212a96
--- /dev/null
+++ b/xbmc/rendering/CMakeLists.txt
@@ -0,0 +1,27 @@
+set(SOURCES RenderSystem.cpp)
+
+set(HEADERS RenderSystem.h
+ RenderSystemTypes.h)
+
+if(OPENGL_FOUND OR OPENGLES_FOUND)
+ list(APPEND SOURCES MatrixGL.cpp)
+ list(APPEND HEADERS MatrixGL.h)
+
+ if(ARCH MATCHES arm AND ENABLE_NEON)
+ list(APPEND SOURCES MatrixGL.neon.cpp)
+ if(NOT DEFINED NEON_FLAGS)
+ set_source_files_properties(MatrixGL.neon.cpp PROPERTIES COMPILE_OPTIONS -mfpu=neon)
+ endif()
+ endif()
+endif()
+
+core_add_library(rendering)
+if(NOT CORE_SYSTEM_NAME STREQUAL windows AND NOT CORE_SYSTEM_NAME STREQUAL windowsstore)
+ if(HAVE_SSE)
+ target_compile_options(${CORE_LIBRARY} PRIVATE -msse)
+ endif()
+ if(HAVE_SSE2)
+ target_compile_options(${CORE_LIBRARY} PRIVATE -msse2)
+ endif()
+endif()
+