summaryrefslogtreecommitdiffstats
path: root/cmake/addons/depends/README
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/addons/depends/README')
-rw-r--r--cmake/addons/depends/README35
1 files changed, 35 insertions, 0 deletions
diff --git a/cmake/addons/depends/README b/cmake/addons/depends/README
new file mode 100644
index 0000000..76df284
--- /dev/null
+++ b/cmake/addons/depends/README
@@ -0,0 +1,35 @@
+KODI ADDON DEPENDENCIES
+=======================
+This directory contains the cmake-based buildsystem for addon dependencies. It
+looks into the "common" and the "<platform>/cmake" sub-directories and parses
+all *.txt files recursively. Each dependency must have its own <dependency>.txt
+file (either in the main sub-directory or in a separate subdirectory of the main
+subdirectory) which must follow one of the defined formats:
+ * an empty file means that no extra downloads are necessary
+ * <dependency>
+ * <dependency> <url>
+ * <dependency> <git-url> <git-revision>
+where
+ * <dependency> must be identical to the filename
+ * <url> must be the URL to an archive that is downloaded and extracted.
+ * <git-url> must be the URL of the git repository containing the
+ dependency.
+ * <git-revision> must be a valid git tag/branch/commit in the dependency's git
+ repository which will be used for the build.
+
+Reserved filenames (for additional information on how to build a dependency)
+are:
+ * CMakeLists.txt: build instructions for the dependency
+ * install.txt: instructions on how to install the dependency's built files
+ * noinstall.txt: no installation step required (content is ignored)
+ * flags.txt: additional build flags
+ * flags-<CPU>.txt: additional arch specific platform build flags
+ * deps.txt: whitespace separated list of dependencies of this dependency
+
+The buildsystem uses the following depends-related variables (which can be passed
+into it when executing cmake with the -D<variable-name>=<value> option) to e.g.
+access specific paths:
+ * DEPENDS_TO_BUILD is a quoted, space delimited list of <dependency>s that
+ you want to build (default is "all").
+ * ADDON_EXTRA_ARGS is a quoted, space delimited list of arguments passed to
+ all <dependency>s built (eg -DADDON_EXTRA_ARGS="-Darg1=1 -Darg2=2").