summaryrefslogtreecommitdiffstats
path: root/xbmc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'xbmc/CMakeLists.txt')
-rw-r--r--xbmc/CMakeLists.txt91
1 files changed, 91 insertions, 0 deletions
diff --git a/xbmc/CMakeLists.txt b/xbmc/CMakeLists.txt
new file mode 100644
index 0000000..4c69707
--- /dev/null
+++ b/xbmc/CMakeLists.txt
@@ -0,0 +1,91 @@
+set(SOURCES AutoSwitch.cpp
+ BackgroundInfoLoader.cpp
+ ContextMenuItem.cpp
+ ContextMenuManager.cpp
+ ContextMenus.cpp
+ CueDocument.cpp
+ DatabaseManager.cpp
+ DbUrl.cpp
+ DynamicDll.cpp
+ FileItem.cpp
+ FileItemListModification.cpp
+ GUIInfoManager.cpp
+ GUILargeTextureManager.cpp
+ GUIPassword.cpp
+ InfoScanner.cpp
+ LangInfo.cpp
+ MediaSource.cpp
+ NfoFile.cpp
+ PasswordManager.cpp
+ PlayListPlayer.cpp
+ PartyModeManager.cpp
+ SectionLoader.cpp
+ SeekHandler.cpp
+ ServiceBroker.cpp
+ ServiceManager.cpp
+ SystemGlobals.cpp
+ TextureCache.cpp
+ TextureCacheJob.cpp
+ TextureDatabase.cpp
+ ThumbLoader.cpp
+ URL.cpp
+ Util.cpp
+ XBDateTime.cpp)
+
+set(HEADERS AutoSwitch.h
+ BackgroundInfoLoader.h
+ CompileInfo.h
+ ContextMenuItem.h
+ ContextMenuManager.h
+ ContextMenus.h
+ CueDocument.h
+ DatabaseManager.h
+ DbUrl.h
+ DllPaths.h
+ DllPaths_win32.h
+ DynamicDll.h
+ FileItem.h
+ FileItemListModification.h
+ GUIInfoManager.h
+ GUILargeTextureManager.h
+ GUIPassword.h
+ GUIUserMessages.h
+ HDRStatus.h
+ IFileItemListModifier.h
+ IProgressCallback.h
+ InfoScanner.h
+ LangInfo.h
+ LockType.h
+ MediaSource.h
+ NfoFile.h
+ PartyModeManager.h
+ PasswordManager.h
+ PlayListPlayer.h
+ SectionLoader.h
+ SeekHandler.h
+ ServiceBroker.h
+ ServiceManager.h
+ SortFileItem.h
+ TextureCache.h
+ TextureCacheJob.h
+ TextureDatabase.h
+ ThumbLoader.h
+ URL.h
+ Util.h
+ XBDateTime.h
+ system_egl.h
+ system_gl.h)
+
+if(ENABLE_OPTICAL)
+ list(APPEND SOURCES Autorun.cpp)
+ list(APPEND HEADERS Autorun.h)
+endif()
+
+core_add_library(xbmc)
+if(CAP_FOUND)
+ target_compile_definitions(${CORE_LIBRARY} PRIVATE -DHAVE_LIBCAP=1)
+endif()
+
+if(CORE_SYSTEM_NAME STREQUAL windowsstore)
+ set_target_properties(${CORE_LIBRARY} PROPERTIES STATIC_LIBRARY_FLAGS "/ignore:4264")
+endif()