summaryrefslogtreecommitdiffstats
path: root/xbmc/powermanagement/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--xbmc/powermanagement/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/xbmc/powermanagement/CMakeLists.txt b/xbmc/powermanagement/CMakeLists.txt
new file mode 100644
index 0000000..a1953d4
--- /dev/null
+++ b/xbmc/powermanagement/CMakeLists.txt
@@ -0,0 +1,14 @@
+set(SOURCES DPMSSupport.cpp
+ IPowerSyscall.cpp
+ PowerManager.cpp)
+
+set(HEADERS DPMSSupport.h
+ IPowerSyscall.h
+ PowerManager.h
+ PowerTypes.h)
+
+if(CORE_SYSTEM_NAME MATCHES windows)
+ list(APPEND HEADERS WinIdleTimer.h)
+endif()
+
+core_add_library(powermanagement)