summaryrefslogtreecommitdiffstats
path: root/xbmc/pvr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--xbmc/pvr/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/xbmc/pvr/CMakeLists.txt b/xbmc/pvr/CMakeLists.txt
new file mode 100644
index 0000000..e7a95a6
--- /dev/null
+++ b/xbmc/pvr/CMakeLists.txt
@@ -0,0 +1,30 @@
+set(SOURCES PVRCachedImage.cpp
+ PVRCachedImages.cpp
+ PVRChannelNumberInputHandler.cpp
+ PVRComponentRegistration.cpp
+ PVRContextMenus.cpp
+ PVRDatabase.cpp
+ PVREdl.cpp
+ PVREventLogJob.cpp
+ PVRItem.cpp
+ PVRManager.cpp
+ PVRPlaybackState.cpp
+ PVRStreamProperties.cpp
+ PVRThumbLoader.cpp)
+
+set(HEADERS IPVRComponent.h
+ PVRCachedImage.h
+ PVRCachedImages.h
+ PVRChannelNumberInputHandler.h
+ PVRComponentRegistration.h
+ PVRContextMenus.h
+ PVRDatabase.h
+ PVREdl.h
+ PVREventLogJob.h
+ PVRItem.h
+ PVRManager.h
+ PVRPlaybackState.h
+ PVRStreamProperties.h
+ PVRThumbLoader.h)
+
+core_add_library(pvr)