summaryrefslogtreecommitdiffstats
path: root/xbmc/threads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'xbmc/threads/CMakeLists.txt')
-rw-r--r--xbmc/threads/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/xbmc/threads/CMakeLists.txt b/xbmc/threads/CMakeLists.txt
new file mode 100644
index 0000000..02e2016
--- /dev/null
+++ b/xbmc/threads/CMakeLists.txt
@@ -0,0 +1,17 @@
+set(SOURCES Event.cpp
+ Thread.cpp
+ Timer.cpp)
+
+set(HEADERS Condition.h
+ CriticalSection.h
+ Event.h
+ Lockables.h
+ SharedSection.h
+ SingleLock.h
+ SystemClock.h
+ Thread.h
+ Timer.h
+ IThreadImpl.h
+ IRunnable.h)
+
+core_add_library(threads)