summaryrefslogtreecommitdiffstats
path: root/xbmc/video/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'xbmc/video/CMakeLists.txt')
-rw-r--r--xbmc/video/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/xbmc/video/CMakeLists.txt b/xbmc/video/CMakeLists.txt
new file mode 100644
index 0000000..00f9baf
--- /dev/null
+++ b/xbmc/video/CMakeLists.txt
@@ -0,0 +1,33 @@
+set(SOURCES Bookmark.cpp
+ ContextMenus.cpp
+ GUIViewStateVideo.cpp
+ PlayerController.cpp
+ Teletext.cpp
+ VideoDatabase.cpp
+ VideoDbUrl.cpp
+ VideoInfoDownloader.cpp
+ VideoInfoScanner.cpp
+ VideoInfoTag.cpp
+ VideoLibraryQueue.cpp
+ VideoThumbLoader.cpp
+ VideoUtils.cpp
+ ViewModeSettings.cpp)
+
+set(HEADERS Bookmark.h
+ ContextMenus.h
+ Episode.h
+ GUIViewStateVideo.h
+ PlayerController.h
+ Teletext.h
+ TeletextDefines.h
+ VideoDatabase.h
+ VideoDbUrl.h
+ VideoInfoDownloader.h
+ VideoInfoScanner.h
+ VideoInfoTag.h
+ VideoLibraryQueue.h
+ VideoThumbLoader.h
+ VideoUtils.h
+ ViewModeSettings.h)
+
+core_add_library(video)