summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b6d5fec
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DUDEV_RULES_DIR=/lib/udev/rules.d \
+ -DCMAKE_BUILD_RPATH_USE_ORIGIN=ON
+
+override_dh_makeshlibs:
+ dh_makeshlibs -- -c4
+
+override_dh_auto_test:
+ debian/run-regression-tests.sh