summaryrefslogtreecommitdiffstats
path: root/fuzzers
diff options
context:
space:
mode:
Diffstat (limited to 'fuzzers')
-rw-r--r--fuzzers/CMakeLists.txt5
-rw-r--r--fuzzers/config_file_fuzzer.c2
-rw-r--r--fuzzers/corpora/revparse/head1
-rw-r--r--fuzzers/corpora/revparse/revat1
-rw-r--r--fuzzers/download_refs_fuzzer.c35
-rw-r--r--fuzzers/fuzzer_utils.c51
-rw-r--r--fuzzers/fuzzer_utils.h14
-rw-r--r--fuzzers/revparse_fuzzer.c52
8 files changed, 128 insertions, 33 deletions
diff --git a/fuzzers/CMakeLists.txt b/fuzzers/CMakeLists.txt
index a2c19ed..01f0f51 100644
--- a/fuzzers/CMakeLists.txt
+++ b/fuzzers/CMakeLists.txt
@@ -12,10 +12,13 @@ foreach(fuzz_target_src ${SRC_FUZZERS})
string(REPLACE ".c" "" fuzz_target_name ${fuzz_target_src})
string(REPLACE "_fuzzer" "" fuzz_name ${fuzz_target_name})
- set(${fuzz_target_name}_SOURCES ${fuzz_target_src} ${LIBGIT2_OBJECTS})
+ set(${fuzz_target_name}_SOURCES
+ ${fuzz_target_src} "fuzzer_utils.c" ${LIBGIT2_OBJECTS})
+
if(USE_STANDALONE_FUZZERS)
list(APPEND ${fuzz_target_name}_SOURCES "standalone_driver.c")
endif()
+
add_executable(${fuzz_target_name} ${${fuzz_target_name}_SOURCES})
set_target_properties(${fuzz_target_name} PROPERTIES C_STANDARD 90)
diff --git a/fuzzers/config_file_fuzzer.c b/fuzzers/config_file_fuzzer.c
index 890adbf..7630369 100644
--- a/fuzzers/config_file_fuzzer.c
+++ b/fuzzers/config_file_fuzzer.c
@@ -43,7 +43,7 @@ int LLVMFuzzerTestOneInput(const uint8_t *data, size_t size)
goto out;
}
- if ((err = git_config_backend_from_string(&backend, (const char*)data, size)) != 0) {
+ if ((err = git_config_backend_from_string(&backend, (const char*)data, size, NULL)) != 0) {
goto out;
}
if ((err = git_config_add_backend(cfg, backend, 0, NULL, 0)) != 0) {
diff --git a/fuzzers/corpora/revparse/head b/fuzzers/corpora/revparse/head
new file mode 100644
index 0000000..e5517e4
--- /dev/null
+++ b/fuzzers/corpora/revparse/head
@@ -0,0 +1 @@
+HEAD \ No newline at end of file
diff --git a/fuzzers/corpora/revparse/revat b/fuzzers/corpora/revparse/revat
new file mode 100644
index 0000000..382ffc0
--- /dev/null
+++ b/fuzzers/corpora/revparse/revat
@@ -0,0 +1 @@
+xxxxxxxxxxxxxxxx@ \ No newline at end of file
diff --git a/fuzzers/download_refs_fuzzer.c b/fuzzers/download_refs_fuzzer.c
index ff95cd1..c2b80cc 100644
--- a/fuzzers/download_refs_fuzzer.c
+++ b/fuzzers/download_refs_fuzzer.c
@@ -16,6 +16,7 @@
#include "futils.h"
#include "standalone_driver.h"
+#include "fuzzer_utils.h"
#define UNUSED(x) (void)(x)
@@ -157,33 +158,10 @@ static int fuzzer_transport_cb(git_transport **out, git_remote *owner, void *par
return git_transport_smart(out, owner, &def);
}
-static void fuzzer_git_abort(const char *op)
-{
- const git_error *err = git_error_last();
- fprintf(stderr, "unexpected libgit error: %s: %s\n",
- op, err ? err->message : "<none>");
- abort();
-}
-
int LLVMFuzzerInitialize(int *argc, char ***argv)
{
-#if defined(_WIN32)
- char tmpdir[MAX_PATH], path[MAX_PATH];
-
- if (GetTempPath((DWORD)sizeof(tmpdir), tmpdir) == 0)
- abort();
-
- if (GetTempFileName(tmpdir, "lg2", 1, path) == 0)
- abort();
-
- if (git_futils_mkdir(path, 0700, 0) < 0)
- abort();
-#else
- char path[] = "/tmp/git2.XXXXXX";
-
- if (mkdtemp(path) != path)
- abort();
-#endif
+ UNUSED(argc);
+ UNUSED(argv);
if (git_libgit2_init() < 0)
abort();
@@ -191,12 +169,7 @@ int LLVMFuzzerInitialize(int *argc, char ***argv)
if (git_libgit2_opts(GIT_OPT_SET_PACK_MAX_OBJECTS, 10000000) < 0)
abort();
- UNUSED(argc);
- UNUSED(argv);
-
- if (git_repository_init(&repo, path, 1) < 0)
- fuzzer_git_abort("git_repository_init");
-
+ repo = fuzzer_repo_init();
return 0;
}
diff --git a/fuzzers/fuzzer_utils.c b/fuzzers/fuzzer_utils.c
new file mode 100644
index 0000000..cde5065
--- /dev/null
+++ b/fuzzers/fuzzer_utils.c
@@ -0,0 +1,51 @@
+/*
+ * Copyright (C) the libgit2 contributors. All rights reserved.
+ *
+ * This file is part of libgit2, distributed under the GNU GPL v2 with
+ * a Linking Exception. For full terms see the included COPYING file.
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+
+#include "git2.h"
+#include "futils.h"
+
+#include "fuzzer_utils.h"
+
+void fuzzer_git_abort(const char *op)
+{
+ const git_error *err = git_error_last();
+ fprintf(stderr, "unexpected libgit error: %s: %s\n",
+ op, err ? err->message : "<none>");
+ abort();
+}
+
+git_repository *fuzzer_repo_init(void)
+{
+ git_repository *repo;
+
+#if defined(_WIN32)
+ char tmpdir[MAX_PATH], path[MAX_PATH];
+
+ if (GetTempPath((DWORD)sizeof(tmpdir), tmpdir) == 0)
+ abort();
+
+ if (GetTempFileName(tmpdir, "lg2", 1, path) == 0)
+ abort();
+
+ if (git_futils_mkdir(path, 0700, 0) < 0)
+ abort();
+#else
+ char path[] = "/tmp/git2.XXXXXX";
+
+ if (mkdtemp(path) != path)
+ abort();
+#endif
+
+ if (git_repository_init(&repo, path, 1) < 0)
+ fuzzer_git_abort("git_repository_init");
+
+ return repo;
+}
diff --git a/fuzzers/fuzzer_utils.h b/fuzzers/fuzzer_utils.h
new file mode 100644
index 0000000..6b67c9a
--- /dev/null
+++ b/fuzzers/fuzzer_utils.h
@@ -0,0 +1,14 @@
+/*
+ * Copyright (C) the libgit2 contributors. All rights reserved.
+ *
+ * This file is part of libgit2, distributed under the GNU GPL v2 with
+ * a Linking Exception. For full terms see the included COPYING file.
+ */
+
+#ifndef INCLUDE_fuzzer_utils_h__
+#define INCLUDE_fuzzer_utils_h__
+
+extern void fuzzer_git_abort(const char *op);
+extern git_repository *fuzzer_repo_init(void);
+
+#endif
diff --git a/fuzzers/revparse_fuzzer.c b/fuzzers/revparse_fuzzer.c
new file mode 100644
index 0000000..37c22e2
--- /dev/null
+++ b/fuzzers/revparse_fuzzer.c
@@ -0,0 +1,52 @@
+/*
+ * libgit2 revparse fuzzer target.
+ *
+ * Copyright (C) the libgit2 contributors. All rights reserved.
+ *
+ * This file is part of libgit2, distributed under the GNU GPL v2 with
+ * a Linking Exception. For full terms see the included COPYING file.
+ */
+
+#include <stdio.h>
+#include <string.h>
+
+#include "git2.h"
+
+#include "standalone_driver.h"
+#include "fuzzer_utils.h"
+
+#define UNUSED(x) (void)(x)
+
+static git_repository *repo;
+
+int LLVMFuzzerInitialize(int *argc, char ***argv)
+{
+ UNUSED(argc);
+ UNUSED(argv);
+
+ if (git_libgit2_init() < 0)
+ abort();
+
+ if (git_libgit2_opts(GIT_OPT_SET_PACK_MAX_OBJECTS, 10000000) < 0)
+ abort();
+
+ repo = fuzzer_repo_init();
+ return 0;
+}
+
+int LLVMFuzzerTestOneInput(const uint8_t *data, size_t size)
+{
+ git_object *obj = NULL;
+ char *c;
+
+ if ((c = calloc(1, size + 1)) == NULL)
+ abort();
+
+ memcpy(c, data, size);
+
+ git_revparse_single(&obj, repo, c);
+ git_object_free(obj);
+ free(c);
+
+ return 0;
+}