summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:40:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:40:56 +0000
commit65d82638fb575397acdc6705938d2f37d04f1eed (patch)
tree8a2690f42ba0cb3cb04ea6707609ca057a1fda7f /debian/rules
parentAdding upstream version 1:0.5.47. (diff)
downloadlibhtp-65d82638fb575397acdc6705938d2f37d04f1eed.tar.xz
libhtp-65d82638fb575397acdc6705938d2f37d04f1eed.zip
Adding debian version 1:0.5.47-1.debian/1%0.5.47-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a8dfb95
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+export DH_VERBOSE=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+override_dh_clean:
+ [ ! -f Makefile ] || make distclean
+ rm -f test/*.o test/main test/Makefile
+ dh_clean
+
+%:
+ dh $@ --with autoreconf