summaryrefslogtreecommitdiffstats
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:40:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 17:40:56 +0000
commitc248d29056abbc1fc4c5dc178bab48fb8d2c1fcb (patch)
tree4a13fc30604509224504e1911bc976e5df7bdf05 /docs/Makefile.am
parentInitial commit. (diff)
downloadlibhtp-c248d29056abbc1fc4c5dc178bab48fb8d2c1fcb.tar.xz
libhtp-c248d29056abbc1fc4c5dc178bab48fb8d2c1fcb.zip
Adding upstream version 1:0.5.47.upstream/1%0.5.47
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
new file mode 100644
index 0000000..57a8325
--- /dev/null
+++ b/docs/Makefile.am
@@ -0,0 +1,18 @@
+CLEANFILES = *.pdf
+
+clean-local:
+ rm -rf doxygen
+
+doxygen: doxygen.conf $(DOXYGEN_DEPS)
+ @if test -n "$(DOXYGEN)"; then \
+ $(DOXYGEN) $<; \
+ else \
+ echo "You need doxygen installed to build the docs."; \
+ fi;
+
+doxygen-pdf: doxygen doxygen.pdf
+
+doxygen.pdf: doxygen
+ (cd doxygen/latex && make refman.pdf) && cp doxygen/latex/refman.pdf doxygen.pdf
+
+.PHONY: doxygen-pdf