summaryrefslogtreecommitdiffstats
path: root/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
new file mode 100644
index 0000000..57a8325
--- /dev/null
+++ b/docs/Makefile.am
@@ -0,0 +1,18 @@
+CLEANFILES = *.pdf
+
+clean-local:
+ rm -rf doxygen
+
+doxygen: doxygen.conf $(DOXYGEN_DEPS)
+ @if test -n "$(DOXYGEN)"; then \
+ $(DOXYGEN) $<; \
+ else \
+ echo "You need doxygen installed to build the docs."; \
+ fi;
+
+doxygen-pdf: doxygen doxygen.pdf
+
+doxygen.pdf: doxygen
+ (cd doxygen/latex && make refman.pdf) && cp doxygen/latex/refman.pdf doxygen.pdf
+
+.PHONY: doxygen-pdf