summaryrefslogtreecommitdiffstats
path: root/src/python/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:47:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:47:37 +0000
commit00e2eb4fd0266c5be01e3a527a66aaad5ab4b634 (patch)
treea6a58bd544eb0b76b9d3acc678ea88791acca045 /src/python/Makefile.am
parentInitial commit. (diff)
downloadlibixion-00e2eb4fd0266c5be01e3a527a66aaad5ab4b634.tar.xz
libixion-00e2eb4fd0266c5be01e3a527a66aaad5ab4b634.zip
Adding upstream version 0.19.0.upstream/0.19.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/python/Makefile.am')
-rw-r--r--src/python/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/python/Makefile.am b/src/python/Makefile.am
new file mode 100644
index 0000000..1dc98c4
--- /dev/null
+++ b/src/python/Makefile.am
@@ -0,0 +1,35 @@
+if BUILD_PYTHON
+
+EXTRA_DIST = test-env.sh
+
+pyexec_LTLIBRARIES = ixion.la
+ixion_la_SOURCES = \
+ document.hpp \
+ document.cpp \
+ global.hpp \
+ global.cpp \
+ python.cpp \
+ sheet.hpp \
+ sheet.cpp
+
+ixion_la_LDFLAGS = -module -avoid-version -export-symbols-regex PyInit_ixion
+ixion_la_CPPFLAGS = -I$(top_srcdir)/include $(PYTHON_CFLAGS) $(MDDS_CFLAGS)
+ixion_la_LIBADD = \
+ ../libixion/libixion-@IXION_API_VERSION@.la \
+ $(PYTHON_LIBS)
+
+if OSX
+
+TESTS = ../../bin/run-python-test-osx.sh
+
+else
+
+AM_TESTS_ENVIRONMENT = . $(srcdir)/test-env.sh;
+
+TESTS = \
+ ../../test/python/document.py \
+ ../../test/python/module.py
+
+endif
+
+endif