summaryrefslogtreecommitdiffstats
path: root/doc_example/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--doc_example/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/doc_example/Makefile.am b/doc_example/Makefile.am
new file mode 100644
index 0000000..d93e7a7
--- /dev/null
+++ b/doc_example/Makefile.am
@@ -0,0 +1,25 @@
+SUBDIRS = section_examples
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ $(MDDS_CFLAGS) $(LIBIXION_CFLAGS) \
+ -DSRCDIR=\""$(top_srcdir)"\"
+
+bin_PROGRAMS =
+
+EXTRA_PROGRAMS = \
+ document-simple \
+ model-context-simple
+
+document_simple_SOURCES = document_simple.cpp
+document_simple_LDADD = ../src/libixion/libixion-@IXION_API_VERSION@.la
+
+model_context_simple_SOURCES = model_context_simple.cpp
+model_context_simple_LDADD = ../src/libixion/libixion-@IXION_API_VERSION@.la
+
+TESTS = \
+ document-simple \
+ model-context-simple
+
+distclean-local:
+ rm -rf $(TESTS)