summaryrefslogtreecommitdiffstats
path: root/include/orcus/spreadsheet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--include/orcus/spreadsheet/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/include/orcus/spreadsheet/Makefile.am b/include/orcus/spreadsheet/Makefile.am
new file mode 100644
index 0000000..b01bce7
--- /dev/null
+++ b/include/orcus/spreadsheet/Makefile.am
@@ -0,0 +1,26 @@
+
+liborcusdir = $(includedir)/liborcus-@ORCUS_API_VERSION@/orcus/spreadsheet
+liborcus_HEADERS = \
+ types.hpp \
+ view_types.hpp \
+ export_interface.hpp \
+ import_interface.hpp \
+ import_interface_pivot.hpp \
+ import_interface_styles.hpp \
+ import_interface_view.hpp
+
+if BUILD_SPREADSHEET_MODEL
+
+liborcus_HEADERS += \
+ auto_filter.hpp \
+ config.hpp \
+ document.hpp \
+ document_types.hpp \
+ factory.hpp \
+ pivot.hpp \
+ shared_strings.hpp \
+ sheet.hpp \
+ styles.hpp \
+ view.hpp
+
+endif