summaryrefslogtreecommitdiffstats
path: root/win32
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:38:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:38:23 +0000
commitff6e3c025658a5fa1affd094f220b623e7e1b24b (patch)
tree9faab72d69c92d24e349d184f5869b9796f17e0c /win32
parentInitial commit. (diff)
downloadlibplacebo-ff6e3c025658a5fa1affd094f220b623e7e1b24b.tar.xz
libplacebo-ff6e3c025658a5fa1affd094f220b623e7e1b24b.zip
Adding upstream version 6.338.2.upstream/6.338.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--win32/demos.manifest16
-rw-r--r--win32/demos.rc.in49
-rw-r--r--win32/libplacebo.manifest22
-rw-r--r--win32/libplacebo.rc.in50
-rw-r--r--win32/meson.build12
5 files changed, 149 insertions, 0 deletions
diff --git a/win32/demos.manifest b/win32/demos.manifest
new file mode 100644
index 0000000..26162e2
--- /dev/null
+++ b/win32/demos.manifest
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
+<assembly manifestVersion="1.0" xmlns="urn:schemas-microsoft-com:asm.v1" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
+ <compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">
+ <description>libplacebo</description>
+ <application>
+ <!-- Windows 10 and Windows 11 -->
+ <supportedOS Id="{8e0f7a12-bfb3-4fe8-b9a5-48fd50a15a9a}"/>
+ <!-- Windows 8.1 -->
+ <supportedOS Id="{1f676c76-80e1-4239-95bb-83d0f6d0da78}"/>
+ <!-- Windows 8 -->
+ <supportedOS Id="{4a2f28e3-53b9-4441-ba9c-d69d4a4a6e38}"/>
+ <!-- Windows 7 -->
+ <supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"/>
+ </application>
+ </compatibility>
+</assembly>
diff --git a/win32/demos.rc.in b/win32/demos.rc.in
new file mode 100644
index 0000000..2357e65
--- /dev/null
+++ b/win32/demos.rc.in
@@ -0,0 +1,49 @@
+/*
+ * This file is part of libplacebo.
+ *
+ * libplacebo is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * libplacebo is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with libplacebo. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#pragma code_page(65001)
+
+#include <winuser.h>
+#include <winver.h>
+#include "version.h"
+
+VS_VERSION_INFO VERSIONINFO
+FILEVERSION @PL_MAJOR@, @PL_MINOR@, @PL_PATCH@
+PRODUCTVERSION @PL_MAJOR@, @PL_MINOR@, @PL_PATCH@
+FILEFLAGSMASK VS_FFI_FILEFLAGSMASK
+FILEFLAGS 0
+FILEOS VOS__WINDOWS32
+FILETYPE VFT_APP
+FILESUBTYPE VFT2_UNKNOWN
+{
+ BLOCK "StringFileInfo" {
+ BLOCK "000004b0" {
+ VALUE "Comments", "libplacebo is distributed under the terms of the GNU Lesser General Public License, version 2.1"
+ VALUE "CompanyName", "libplacebo"
+ VALUE "FileDescription", "libplacebo"
+ VALUE "FileVersion", BUILD_VERSION
+ VALUE "LegalCopyright", "Copyright © 2017-2023 libplacebo project"
+ VALUE "ProductName", "libplacebo"
+ VALUE "ProductVersion", BUILD_VERSION
+ }
+ }
+ BLOCK "VarFileInfo" {
+ VALUE "Translation", 0, 1200
+ }
+}
+
+CREATEPROCESS_MANIFEST_RESOURCE_ID RT_MANIFEST "demos.manifest"
diff --git a/win32/libplacebo.manifest b/win32/libplacebo.manifest
new file mode 100644
index 0000000..ca49eac
--- /dev/null
+++ b/win32/libplacebo.manifest
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
+<assembly manifestVersion="1.0" xmlns="urn:schemas-microsoft-com:asm.v1" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3">
+ <compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">
+ <assemblyIdentity
+ version="1.0.0.0"
+ processorArchitecture="*"
+ name="libplacebo.dll"
+ type="win32"
+ />
+ <description>libplacebo</description>
+ <application>
+ <!-- Windows 10 and Windows 11 -->
+ <supportedOS Id="{8e0f7a12-bfb3-4fe8-b9a5-48fd50a15a9a}"/>
+ <!-- Windows 8.1 -->
+ <supportedOS Id="{1f676c76-80e1-4239-95bb-83d0f6d0da78}"/>
+ <!-- Windows 8 -->
+ <supportedOS Id="{4a2f28e3-53b9-4441-ba9c-d69d4a4a6e38}"/>
+ <!-- Windows 7 -->
+ <supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"/>
+ </application>
+ </compatibility>
+</assembly>
diff --git a/win32/libplacebo.rc.in b/win32/libplacebo.rc.in
new file mode 100644
index 0000000..a665e47
--- /dev/null
+++ b/win32/libplacebo.rc.in
@@ -0,0 +1,50 @@
+/*
+ * This file is part of libplacebo.
+ *
+ * libplacebo is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * libplacebo is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with libplacebo. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#pragma code_page(65001)
+
+#include <winuser.h>
+#include <winver.h>
+#include "version.h"
+
+VS_VERSION_INFO VERSIONINFO
+FILEVERSION @PL_MAJOR@, @PL_MINOR@, @PL_PATCH@
+PRODUCTVERSION @PL_MAJOR@, @PL_MINOR@, @PL_PATCH@
+FILEFLAGSMASK VS_FFI_FILEFLAGSMASK
+FILEFLAGS 0
+FILEOS VOS__WINDOWS32
+FILETYPE VFT_DLL
+FILESUBTYPE VFT2_UNKNOWN
+{
+ BLOCK "StringFileInfo" {
+ BLOCK "000004b0" {
+ VALUE "Comments", "libplacebo is distributed under the terms of the GNU Lesser General Public License, version 2.1"
+ VALUE "CompanyName", "libplacebo"
+ VALUE "FileDescription", "libplacebo"
+ VALUE "FileVersion", BUILD_VERSION
+ VALUE "LegalCopyright", "Copyright © 2017-2023 libplacebo project"
+ VALUE "OriginalFilename", "libplacebo-@PL_MINOR@.dll"
+ VALUE "ProductName", "libplacebo"
+ VALUE "ProductVersion", BUILD_VERSION
+ }
+ }
+ BLOCK "VarFileInfo" {
+ VALUE "Translation", 0, 1200
+ }
+}
+
+CREATEPROCESS_MANIFEST_RESOURCE_ID RT_MANIFEST "libplacebo.manifest"
diff --git a/win32/meson.build b/win32/meson.build
new file mode 100644
index 0000000..9226312
--- /dev/null
+++ b/win32/meson.build
@@ -0,0 +1,12 @@
+version_arr = meson.project_version().split('.')
+version_config = configuration_data()
+version_config.set('PL_MAJOR', version_arr[0])
+version_config.set('PL_MINOR', version_arr[1])
+version_config.set('PL_PATCH', version_arr[2])
+
+libplacebo_rc = configure_file(input: 'libplacebo.rc.in',
+ output: 'libplacebo.rc',
+ configuration: version_config)
+demos_rc = configure_file(input: 'demos.rc.in',
+ output: 'demos.rc',
+ configuration: version_config)