summaryrefslogtreecommitdiffstats
path: root/avmedia/Library_avmediaMacAVF.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /avmedia/Library_avmediaMacAVF.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'avmedia/Library_avmediaMacAVF.mk')
-rw-r--r--avmedia/Library_avmediaMacAVF.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/avmedia/Library_avmediaMacAVF.mk b/avmedia/Library_avmediaMacAVF.mk
new file mode 100644
index 0000000000..388a9fba13
--- /dev/null
+++ b/avmedia/Library_avmediaMacAVF.mk
@@ -0,0 +1,45 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,avmediaMacAVF))
+
+$(eval $(call gb_Library_set_componentfile,avmediaMacAVF,avmedia/source/macavf/avmediaMacAVF,services))
+
+$(eval $(call gb_Library_set_include,avmediaMacAVF,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/avmedia/source/inc \
+))
+
+$(eval $(call gb_Library_use_external,avmediaMacAVF,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,avmediaMacAVF));
+
+$(eval $(call gb_Library_use_libraries,avmediaMacAVF,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ tl \
+ vcl \
+))
+
+$(eval $(call gb_Library_use_system_darwin_frameworks,avmediaMacAVF,\
+ AVFoundation \
+ Cocoa \
+ CoreMedia \
+))
+
+$(eval $(call gb_Library_add_objcxxobjects,avmediaMacAVF,\
+ avmedia/source/macavf/framegrabber \
+ avmedia/source/macavf/manager \
+ avmedia/source/macavf/player \
+ avmedia/source/macavf/window \
+))
+
+# vim: set noet sw=4 ts=4: