summaryrefslogtreecommitdiffstats
path: root/binaryurp/CppunitTest_binaryurp_test-unmarshal.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /binaryurp/CppunitTest_binaryurp_test-unmarshal.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'binaryurp/CppunitTest_binaryurp_test-unmarshal.mk')
-rw-r--r--binaryurp/CppunitTest_binaryurp_test-unmarshal.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/binaryurp/CppunitTest_binaryurp_test-unmarshal.mk b/binaryurp/CppunitTest_binaryurp_test-unmarshal.mk
new file mode 100644
index 0000000000..11c70f5b9d
--- /dev/null
+++ b/binaryurp/CppunitTest_binaryurp_test-unmarshal.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,binaryurp_test-unmarshal))
+
+$(eval $(call gb_CppunitTest_use_external,binaryurp_test-unmarshal,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_libraries,binaryurp_test-unmarshal,\
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_CppunitTest_use_library_objects,binaryurp_test-unmarshal,\
+ binaryurp \
+))
+
+$(eval $(call gb_CppunitTest_use_api,binaryurp_test-unmarshal,\
+ udkapi \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,binaryurp_test-unmarshal,\
+ binaryurp/qa/test-unmarshal \
+))
+
+# vim: set noet sw=4 ts=4: