summaryrefslogtreecommitdiffstats
path: root/chart2/Module_chart2.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /chart2/Module_chart2.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'chart2/Module_chart2.mk')
-rw-r--r--chart2/Module_chart2.mk59
1 files changed, 59 insertions, 0 deletions
diff --git a/chart2/Module_chart2.mk b/chart2/Module_chart2.mk
new file mode 100644
index 0000000000..5f7fd5aee9
--- /dev/null
+++ b/chart2/Module_chart2.mk
@@ -0,0 +1,59 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+include $(SRCDIR)/chart2/import_setup.mk
+include $(SRCDIR)/chart2/export_setup.mk
+
+$(eval $(call gb_Module_Module,chart2))
+
+$(eval $(call gb_Module_add_targets,chart2,\
+ Library_chartcontroller \
+ Library_chartcore \
+ UIConfig_chart2 \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,chart2,\
+ AllLangMoTarget_chart \
+))
+
+ifneq ($(OS),iOS)
+$(eval $(call gb_Module_add_check_targets,chart2,\
+ CppunitTest_chart2_common_functors \
+))
+
+$(eval $(call gb_Module_add_slowcheck_targets,chart2,\
+ CppunitTest_chart2_export \
+ CppunitTest_chart2_export2 \
+ CppunitTest_chart2_export3 \
+ CppunitTest_chart2_import \
+ CppunitTest_chart2_import2 \
+ CppunitTest_chart2_trendcalculators \
+ CppunitTest_chart2_dump \
+ CppunitTest_chart2_pivot_chart_test \
+ CppunitTest_chart2_geometry \
+ CppunitTest_chart2_uichart \
+))
+
+ifeq ($(WITH_FONTS), TRUE)
+$(eval $(call gb_Module_add_slowcheck_targets,chart2,\
+ CppunitTest_chart2_xshape \
+))
+endif
+
+$(eval $(call gb_Module_add_subsequentcheck_targets,chart2,\
+ JunitTest_chart2_unoapi \
+))
+
+# screenshots
+$(eval $(call gb_Module_add_screenshot_targets,chart2,\
+ CppunitTest_chart2_dialogs_test \
+))
+endif
+
+# vim: set noet sw=4 ts=4: