summaryrefslogtreecommitdiffstats
path: root/cpputools/Executable_uno.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 05:54:39 +0000
commit267c6f2ac71f92999e969232431ba04678e7437e (patch)
tree358c9467650e1d0a1d7227a21dac2e3d08b622b2 /cpputools/Executable_uno.mk
parentInitial commit. (diff)
downloadlibreoffice-267c6f2ac71f92999e969232431ba04678e7437e.tar.xz
libreoffice-267c6f2ac71f92999e969232431ba04678e7437e.zip
Adding upstream version 4:24.2.0.upstream/4%24.2.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'cpputools/Executable_uno.mk')
-rw-r--r--cpputools/Executable_uno.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/cpputools/Executable_uno.mk b/cpputools/Executable_uno.mk
new file mode 100644
index 0000000000..f3106c304b
--- /dev/null
+++ b/cpputools/Executable_uno.mk
@@ -0,0 +1,29 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,uno))
+
+$(eval $(call gb_Executable_use_internal_comprehensive_api,uno,\
+ udkapi \
+))
+
+$(eval $(call gb_Executable_use_libraries,uno,\
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,uno,\
+ cpputools/source/unoexe/unoexe \
+))
+
+$(eval $(call gb_Executable_add_default_nativeres,uno))
+
+# vim:set noet sw=4 ts=4: